% pip install xyz
> 4 errors, 25 warning

Literally npm levels of disgusting 😖

Follow

Here's a good idea: if installing a package throws an error, then abort and remove it.

Don't tell me it successfully installed with 4 errors. That's fucking insane.

And honestly warnings other than deprecation warnings should probably just be errors.

Like, there's no reason installing a package would cause warnings but be perfectly functional.

Sign in to participate in the conversation
Mastodon

Mastodon Community of Denmark (MCD) for Danes and other people to talk about Denmark or whatever.